Browser Support

ATTENTION: Your web browser does not include a necessary upgrade that keeps your information safe while sharing personal data over the Internet.  On June 1, 2018, Kentucky Farm Bureau will require all web browsers to be updated in order to access this website (kyfb.com) and our Member Portal (my.kyfb.com).

How can you fix this? Simply download the newest version of your web browser to your computer and the problem should be automatically resolved.

Download link for Internet Explorer browser

Download link for Chrome browser

Download link for Firefox browser

If you do not update your web browser by June 1, 2018, you will no longer be able to securely connect with this website (kyfb.com) or our Member Portal (my.kyfb.com).  This requirement is being put in place to better protect your personal information and is not exclusive to Kentucky Farm Bureau. This will also affect your access to any other financial website that you may use.

Thank you for your compliance and understanding our commitment to the security of your personal data.